// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)<[^>]+(*SKIP)(*F)|[a-z]?\d{5}").unwrap();
let string = "<a href=\"#\" title=\"Sample Fee – also see B11023\">G14015</a>";
let substitution = "B";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}