# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(I like to find )(.*)( in )([^.]*)(\.)(.*)/$4 $2/s;t' <<< "I like to find something vicous in somewhere bla bla bla.
https://address.suffix.com/level/somelongurlstuff"