// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(I like to find )(.*)( in )([^.]*)(\.)(.*)").unwrap();
let string = "I like to find something vicous in somewhere bla bla bla.
https://address.suffix.com/level/somelongurlstuff";
let substitution = "$4 $2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}