# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(I like to find )(.*)( in )([^.]*)(\.)(.*)"
test_str = ("I like to find something vicous in somewhere bla bla bla.\n"
"https://address.suffix.com/level/somelongurlstuff")
subst = "$4 $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.