use strict;
my $str = 'I like to find something vicous in somewhere bla bla bla.
https://address.suffix.com/level/somelongurlstuff';
my $regex = qr/(I like to find )(.*)( in )([^.]*)(\.)(.*)/sp;
my $subst = '$4 $2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";