$re = '/(I like to find )(.*)( in )([^.]*)(\.)(.*)/s';
$str = 'I like to find something vicous in somewhere bla bla bla.
https://address.suffix.com/level/somelongurlstuff';
$subst = "$4 $2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;