re = /(I like to find )(.*)( in )([^.]*)(\.)(.*)/
str = 'I like to find something vicous in somewhere bla bla bla.
https://address.suffix.com/level/somelongurlstuff'
subst = '$4 $2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result