using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(I like to find )(.*)( in )([^.]*)(\.)(.*)";
string substitution = @"$4 $2";
string input = @"I like to find something vicous in somewhere bla bla bla.
https://address.suffix.com/level/somelongurlstuff";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}