import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(I like to find )(.*)( in )([^.]*)(\\.)(.*)";
final String string = "I like to find something vicous in somewhere bla bla bla.\n"
+ "https://address.suffix.com/level/somelongurlstuff";
final String subst = "$4 $2";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}