const regex = /(I like to find )(.*)( in )([^.]*)(\.)(.*)/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(I like to find )(.*)( in )([^.]*)(\\.)(.*)', 's')
const str = `I like to find something vicous in somewhere bla bla bla.
https://address.suffix.com/level/somelongurlstuff`;
const subst = `$4 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);