#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[URL=[^]]*?\](.*?)\[\/URL\]"
Local $sString = "[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type="full" width="30%" alt="Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb"]1319[/ATTACH][/URL]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type="full" width="30%" alt="Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb"]1319[/ATTACH][/URL]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")