use strict;
my $str = '[URL=\'http://filedata/fetch?id=2151&d=1612502132\'][ATTACH type="full" width="30%" alt="Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb"]1319[/ATTACH][/URL]
[URL=\'http://filedata/fetch?id=2151&d=1612502132\'][ATTACH type="full" width="30%" alt="Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb"]1319[/ATTACH][/URL]
';
my $regex = qr/\[URL=[^]]*?\](.*?)\[\/URL\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}