using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[URL=[^]]*?\](.*?)\[\/URL\]";
string input = @"[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type=""full"" width=""30%"" alt=""Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb""]1319[/ATTACH][/URL]
[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type=""full"" width=""30%"" alt=""Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb""]1319[/ATTACH][/URL]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}