const regex = /\[URL=[^]]*?\](.*?)\[\/URL\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[URL=[^]]*?\\](.*?)\\[\\\/URL\\]', 'gm')
const str = `[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type="full" width="30%" alt="Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb"]1319[/ATTACH][/URL]
[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type="full" width="30%" alt="Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb"]1319[/ATTACH][/URL]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}