// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[URL=[^]]*?\](.*?)\[\/URL\]").unwrap();
let string = "[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type=\"full\" width=\"30%\" alt=\"Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb\"]1319[/ATTACH][/URL]
[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type=\"full\" width=\"30%\" alt=\"Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb\"]1319[/ATTACH][/URL]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}