$re = '/\[URL=[^]]*?\](.*?)\[\/URL\]/m';
$str = '[URL=\'http://filedata/fetch?id=2151&d=1612502132\'][ATTACH type="full" width="30%" alt="Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb"]1319[/ATTACH][/URL]
[URL=\'http://filedata/fetch?id=2151&d=1612502132\'][ATTACH type="full" width="30%" alt="Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb"]1319[/ATTACH][/URL]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);