# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[URL=[^]]*?\](.*?)\[\/URL\]"
test_str = ("[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type=\"full\" width=\"30%\" alt=\"Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb\"]1319[/ATTACH][/URL]\n\n\n"
"[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type=\"full\" width=\"30%\" alt=\"Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb\"]1319[/ATTACH][/URL]\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.