import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[URL=[^]]*?\\](.*?)\\[\\/URL\\]";
final String string = "[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type=\"full\" width=\"30%\" alt=\"Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb\"]1319[/ATTACH][/URL]\n\n\n"
+ "[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type=\"full\" width=\"30%\" alt=\"Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb\"]1319[/ATTACH][/URL]\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}