import Foundation
let pattern = #"\[URL=[^]]*?\](.*?)\[\/URL\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type="full" width="30%" alt="Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb"]1319[/ATTACH][/URL]
[URL='http://filedata/fetch?id=2151&d=1612502132'][ATTACH type="full" width="30%" alt="Click for bigger size. Name: DJ824_0.jpg Views: 0 Size: 195.1 Kb"]1319[/ATTACH][/URL]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)