#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?:\G(?!^)|^genre:\h*").*?\K",\h*""
Local $sString = "genre: "drama", "thriller", "mystery", "espionage"" & @CRLF & _
"genre: "drama", "sci-fi"" & @CRLF & _
"NOT genre: "drama", "sci-fi""
Local $sSubst = ", "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)