const regex = /(?:\G(?!^)|^genre:\h*").*?\K",\h*"/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|^genre:\\h*").*?\\K",\\h*"', 'gmi')
const str = `genre: "drama", "thriller", "mystery", "espionage"
genre: "drama", "sci-fi"
NOT genre: "drama", "sci-fi"`;
const subst = `, `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);