using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|^genre:\h*"").*?\K"",\h*""";
string substitution = @", ";
string input = @"genre: ""drama"", ""thriller"", ""mystery"", ""espionage""
genre: ""drama"", ""sci-fi""
NOT genre: ""drama"", ""sci-fi""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}