use strict;
my $str = 'genre: "drama", "thriller", "mystery", "espionage"
genre: "drama", "sci-fi"
NOT genre: "drama", "sci-fi"';
my $regex = qr/(?:\G(?!^)|^genre:\h*").*?\K",\h*"/mip;
my $subst = ', ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";