re = /(?:\G(?!^)|^genre:\h*").*?\K",\h*"/mi
str = 'genre: "drama", "thriller", "mystery", "espionage"
genre: "drama", "sci-fi"
NOT genre: "drama", "sci-fi"'
subst = ', '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result