$re = '/(?:\G(?!^)|^genre:\h*").*?\K",\h*"/mi';
$str = 'genre: "drama", "thriller", "mystery", "espionage"
genre: "drama", "sci-fi"
NOT genre: "drama", "sci-fi"';
$subst = ", ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;