import Foundation
let pattern = #"(?:\G(?!^)|^genre:\h*").*?\K",\h*""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
genre: "drama", "thriller", "mystery", "espionage"
genre: "drama", "sci-fi"
NOT genre: "drama", "sci-fi"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #", "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)