# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("{3}|["\'])(?:(?=(\\?))\2.)*?\1/<span class='string'>\0<\/span>/gs;t' <<< "\"AbcD\"
'AbcD'"