# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r'("{3}|["\'])(?:(?=(\\?))\2.)*?\1'
test_str = ("\"AbcD\"\n\n"
"'AbcD'")
subst = "<span class='string'>\\0</span>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur'' to prefix the regex and u"" to prefix the test string and substitution.