use strict;
my $str = '"AbcD"
\'AbcD\'';
my $regex = qr/("{3}|["\'])(?:(?=(\\?))\2.)*?\1/sp;
my $subst = '<span class=\'string\'>\\0</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";