const regex = new RegExp('("{3}|["\\\\'])(?:(?=(\\\\?))\\2.)*?\\1', 'gs')
const str = `"AbcD"
'AbcD'`;
const subst = `<span class='string'>\0</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);