import Foundation
let pattern = #"("{3}|["\'])(?:(?=(\\?))\2.)*?\1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
"AbcD"
'AbcD'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span class='string'>\0</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)