using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""{3}|[""\'])(?:(?=(\\?))\2.)*?\1";
string substitution = @"<span class='string'>\0</span>";
string input = @"""AbcD""
'AbcD'";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}