re = /("{3}|["\'])(?:(?=(\\?))\2.)*?\1/
str = '"AbcD"
\'AbcD\''
subst = '<span class=\'string\'>\\0</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result