#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)("{3}|["\'])(?:(?=(\\?))\2.)*?\1"
Local $sString = ""AbcD"" & @CRLF & _
"" & @CRLF & _
"'AbcD'"
Local $sSubst = "<span class='string'>\0</span>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)