import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"{3}|[\"\\'])(?:(?=(\\\\?))\\2.)*?\\1";
final String string = "\"AbcD\"\n\n"
+ "'AbcD'";
final String subst = "<span class='string'>\\0</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}