package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\/w\d*?\/`)
var str = `/w/
/w860/
/w89/
"https://img10.static-smb.be/a/view/q75/w138/h97/1783176/mooiste-billen-sport-jpg.jpg"
"https://img10.static-smb.be/a/view/q75/w/h97/1783176/mooiste-billen-sport-jpg.jpg"
`
var substitution = "/w138/"
fmt.Println(re.ReplaceAllString(str, substitution))
}