use strict;
my $str = '/w/
/w860/
/w89/
"https://img10.static-smb.be/a/view/q75/w138/h97/1783176/mooiste-billen-sport-jpg.jpg"
"https://img10.static-smb.be/a/view/q75/w/h97/1783176/mooiste-billen-sport-jpg.jpg"
';
my $regex = qr/\/w\d*?\//mip;
my $subst = '/w138/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";