import Foundation
let pattern = #"\/w\d*?\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
/w/
/w860/
/w89/
"https://img10.static-smb.be/a/view/q75/w138/h97/1783176/mooiste-billen-sport-jpg.jpg"
"https://img10.static-smb.be/a/view/q75/w/h97/1783176/mooiste-billen-sport-jpg.jpg"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/w138/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)