# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/w\d*?\/"
test_str = ("/w/\n"
"/w860/\n"
"/w89/\n\n"
"\"https://img10.static-smb.be/a/view/q75/w138/h97/1783176/mooiste-billen-sport-jpg.jpg\"\n\n"
"\"https://img10.static-smb.be/a/view/q75/w/h97/1783176/mooiste-billen-sport-jpg.jpg\"\n\n\n")
subst = "/w138/"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.