// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\/w\d*?\/").unwrap();
let string = "/w/
/w860/
/w89/
\"https://img10.static-smb.be/a/view/q75/w138/h97/1783176/mooiste-billen-sport-jpg.jpg\"
\"https://img10.static-smb.be/a/view/q75/w/h97/1783176/mooiste-billen-sport-jpg.jpg\"
";
let substitution = "/w138/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}