re = /\/w\d*?\//mi
str = '/w/
/w860/
/w89/
"https://img10.static-smb.be/a/view/q75/w138/h97/1783176/mooiste-billen-sport-jpg.jpg"
"https://img10.static-smb.be/a/view/q75/w/h97/1783176/mooiste-billen-sport-jpg.jpg"
'
subst = '/w138/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result