const regex = /\/w\d*?\//gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/w\\d*?\\\/', 'gmi')
const str = `/w/
/w860/
/w89/
"https://img10.static-smb.be/a/view/q75/w138/h97/1783176/mooiste-billen-sport-jpg.jpg"
"https://img10.static-smb.be/a/view/q75/w/h97/1783176/mooiste-billen-sport-jpg.jpg"
`;
const subst = `/w138/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);