#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)repository:\s+['"]?(?<depName>[_\-\/\w]+)['"]?,?\s+tag:\s+['"]?(?<currentValue>[_\-\.\w]+)['"]?"
Local $sString = " image: { repository: user_name-123/repo_name-123, tag: v1.23.45_amd64-cluster }" & @CRLF & _
"" & @CRLF & _
" image:" & @CRLF & _
" repository: "user_name-123/repo_name-123"" & @CRLF & _
" tag: 'v1.23.45_amd64-cluster'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")