import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "repository:\\s+['\"]?(?<depName>[_\\-\\/\\w]+)['\"]?,?\\s+tag:\\s+['\"]?(?<currentValue>[_\\-\\.\\w]+)['\"]?";
final String string = " image: { repository: user_name-123/repo_name-123, tag: v1.23.45_amd64-cluster }\n\n"
+ " image:\n"
+ " repository: \"user_name-123/repo_name-123\"\n"
+ " tag: 'v1.23.45_amd64-cluster'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}