import re
regex = re.compile(r"repository:\s+['\"]?(?<depName>[_\-\/\w]+)['\"]?,?\s+tag:\s+['\"]?(?<currentValue>[_\-\.\w]+)['\"]?", flags=re.MULTILINE)
test_str = (" image: { repository: user_name-123/repo_name-123, tag: v1.23.45_amd64-cluster }\n\n"
" image:\n"
" repository: \"user_name-123/repo_name-123\"\n"
" tag: 'v1.23.45_amd64-cluster'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")