re = /repository:\s+['"]?(?<depName>[_\-\/\w]+)['"]?,?\s+tag:\s+['"]?(?<currentValue>[_\-\.\w]+)['"]?/m
str = ' image: { repository: user_name-123/repo_name-123, tag: v1.23.45_amd64-cluster }
image:
repository: "user_name-123/repo_name-123"
tag: \'v1.23.45_amd64-cluster\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end