$re = '/repository:\s+[\'"]?(?<depName>[_\-\/\w]+)[\'"]?,?\s+tag:\s+[\'"]?(?<currentValue>[_\-\.\w]+)[\'"]?/m';
$str = ' image: { repository: user_name-123/repo_name-123, tag: v1.23.45_amd64-cluster }
image:
repository: "user_name-123/repo_name-123"
tag: \'v1.23.45_amd64-cluster\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);