import Foundation
let pattern = #"repository:\s+['"]?(?<depName>[_\-\/\w]+)['"]?,?\s+tag:\s+['"]?(?<currentValue>[_\-\.\w]+)['"]?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
image: { repository: user_name-123/repo_name-123, tag: v1.23.45_amd64-cluster }
image:
repository: "user_name-123/repo_name-123"
tag: 'v1.23.45_amd64-cluster'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)