using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"repository:\s+['""]?(?<depName>[_\-\/\w]+)['""]?,?\s+tag:\s+['""]?(?<currentValue>[_\-\.\w]+)['""]?";
string input = @" image: { repository: user_name-123/repo_name-123, tag: v1.23.45_amd64-cluster }
image:
repository: ""user_name-123/repo_name-123""
tag: 'v1.23.45_amd64-cluster'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}