// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)repository:\s+['"]?(?<depName>[_\-\/\w]+)['"]?,?\s+tag:\s+['"]?(?<currentValue>[_\-\.\w]+)['"]?"#).unwrap();
let string = " image: { repository: user_name-123/repo_name-123, tag: v1.23.45_amd64-cluster }
image:
repository: \"user_name-123/repo_name-123\"
tag: 'v1.23.45_amd64-cluster'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}